Забыл пароль администратора

Цікава інформація для наших клієнтів
Відповісти
max82
Повідомлень: 26
З нами з: 05 березня 2014, 12:49

Забыл пароль администратора

Повідомлення max82 » 04 січня 2017, 18:14

Извините, может тему создал не в том разделе. Но подного не нашел. Проблема в том что я забыл пароль. Или ввожу не так, там ошибится трудно. но программа пишет что пароль не верен. Помогите пожалуйста. Службы медка запущены. Перезапускал. Пользователи входят. Я зайти не могу. А нужно обновиться.

priup
Повідомлень: 7214
З нами з: 22 червня 2011, 12:23

Re: Забыл пароль администратора

Повідомлення priup » 04 січня 2017, 18:20

Я бы переустанавливал, с восстановлением Р/К из .ZBK
Хотя может Ваш дилер поспрашает в БО ........

max82
Повідомлень: 26
З нами з: 05 березня 2014, 12:49

Re: Забыл пароль администратора

Повідомлення max82 » 04 січня 2017, 18:26

если бы я был рядом с сервером, то полез переустанавливать. А так, нахожусь далеко от него и работаю через Тиам виер. Возле сервера буду недели через две. А надо сейчас.

Inkognito
Повідомлень: 990
З нами з: 14 січня 2012, 14:26

Re: Забыл пароль администратора

Повідомлення Inkognito » 04 січня 2017, 18:48

Код для простенькой обработки 1С | Показать
App = Новый COMОбъект("MEDOC.ZApplication");
Dict = App.GetDictionary();
tabl = Dict.Open("IUSER");
tabl.Filter="NAME=Admin";
tabl.First();
Если tabl.RecordCount()=1 Тогда
tabl.Edit();
tabl.Fields.Item("Passwd").Value = "";
tabl.Post();

isReadOnly = Dict.IsReadOnly();
Если НЕ isReadOnly Тогда
Dict.Save();
КонецЕсли;
КонецЕсли;
Сообщить("Пароль для админа удален!");
П.С. не пробовал
П.П.С установите IBExpert, если Вы админ Медка, может еще пригодится. Заходите в соответсвующую таблицу "IUSER", грохаете значение в поле "Passwd" для админа (или кого там хотите разблокировать).
Рабочий перепроверенный код | Показать
App = Новый COMОбъект("MEDOC.ZApplication");
Dict = App.GetDictionary();
tabl = Dict.Open("IUSER");
//по непонятной прчиние, упорно не хочет фильтровать по названию пользователя. Пришлось брать 0 строку (в котой всегда админ):
//tabl.Filter=Строка("NAME=Admin");
//tabl.Filter=Строка("NAME=") + Строка("Admin");
tabl.Filter=Строка("RCD=") + Строка("0");
//--------------------------

tabl.First();
Если tabl.RecordCount()=1 Тогда
tabl.Edit();
tabl.Fields.Item("Passwd").Value = "";
tabl.Post();

isReadOnly = Dict.IsReadOnly();
Если НЕ isReadOnly Тогда
Dict.Save();
Сообщить("Пароль для админа удален!");
КонецЕсли;
КонецЕсли;

Bambi3
Повідомлень: 1
З нами з: 12 лютого 2021, 01:51

Re: Забыл пароль администратора

Повідомлення Bambi3 » 12 лютого 2021, 01:57

Таже ситуация. Выбрасывает и не дает зайти в учетку

rsv
Повідомлень: 1604
З нами з: 08 жовтня 2012, 18:20
Звідки: Гондурас

Re: Забыл пароль администратора

Повідомлення rsv » 12 лютого 2021, 10:16

Є один варіант - пальці в двері. Люди казали що допомагало (правда в їхній ситуації там пароль на ключ тре було згадати)
Людський мозок - це порожнє горище, куди можна набити все, що завгодно. Дурень так і робить: тягне туди потрібне і непотрібне. І нарешті настає момент, коли найнеобхіднішу річ туди вже не запхнеш...

Roman Brashchenko
Повідомлень: 222
З нами з: 11 грудня 2019, 17:44

Re: Забыл пароль администратора

Повідомлення Roman Brashchenko » 12 лютого 2021, 10:22

Bambi3 писав:
12 лютого 2021, 01:57
Таже ситуация. Выбрасывает и не дает зайти в учетку
Добрый день. Опишите более детально Вашу проблему со всеми вводными данными

Відповісти

Повернутись до “Корисна інформація”